Filo doesn't respond in new guilds
Incident Report for Filo
Resolved
This incident has been resolved.
Posted Apr 03, 2021 - 20:33 CEST
Investigating
We are currently investigating this issue.
Posted Apr 03, 2021 - 20:30 CEST
This incident affected: Filo (Shard #0, Shard #1, Shard #2, Shard #3, Shard #4).